Jere's Techblog

Troubleshooting an App-V issue on a PVS image

This blog entry is based on the following, a little bit outdated article:

The problem is unfortunately still current it just brings some changes with Microsoft Server 2016. Therefore I took the liberty to copy some explanations from the “old article”.

Problem Description

During a recent application implementation project, we ran into the following issue. Some App-V applications, which were installed locally in the PVS image, were unable to start or they were throwing various error messages. One of the applications which were showing errors, was MS Office (Word, Excel, Powerpoint) viewer. The error thrown at startup of the application was the following: “The operating system is not presently configured to run this application.”

The App-V client was 5.0 SP2, but App-V 5.0 SP3 was also used as a troubleshooting step. The PVS target devices were configured as such:
Streamed disk
Persistent disk (flush overflow)
Re-installing the application in the image, solved the issue for that particular application. However, we wanted to know the root cause of this issue, so we logged a case at Citrix. This was done because the behavior was not existing on a regular non-streamed VM.
After extensive troubleshooting together with Citrix support we discovered the root cause:
One of the registry keys (HKLM\SOFTWARE\Microsoft\AppV\MAV\Configuration\Packages\<package ID>) containing the PackageRoot value contained a faulty HarddiskVolume number.
This volume was indicated as 3, whereas the streamed disk volume number was 2.

Solution

Correcting HarddiskVolume3 into HarddiskVolume2 did solve the issue.
The reason why the HarddiskVolume3 value got into the registry was because these applications where installed in the image on the template machine. This was the machine from which the initial vdisk was captured. During the installation of the particular App-V applications, the original disk was still attached .


This is issue is definitely not Citrix or PVS related, but can be encountered on such a setup.
To prevent this issue from happening again in the future, the original disk was detached from the template VM.

You can get the disknumber in CMD with “DISKPART -> ListDisk” or PowerShell “Get-Disk”.

My expirience and solution with this issue on Server 2016:

In our Environment we ran into the same problem and we could fix this on Server 2008R2 & Citrix 6.5, PVS 7.15 with the modification of one of the registry keys (with a Startupscript during worker boot). (HKLM\SOFTWARE\Microsoft\AppV\MAV\Configuration\Packages\<package ID>) containing the PackageRoot value contained a faulty HarddiskVolume number.

On Server 2016 (Citrix 7.17) everything was useless. Creating or deleting a disk on the masterimage or changing the RegKey didn’t work. I also didn’t find a way to change the disk volume number.

The problem could only be solved by adjusting the call parameter of the application. If the application is started in the App-V context it works fine.

As an example:

Microsoft InfoPath 2013

C:\ProgramData\Microsoft\AppV\Client\Integration\D24C3BDD-8FAD-44D3-998C-933F8F053682\Root\Office15\INFOPATH.EXE /appvve:d24c3bdd-8fad-44d3-998c-933f8f053682_6b0281c5-bb0b-49fb-b52c-a6651e8ed2ed

filetype associations fix

to fix the filetype associations you need to add the “/appvee:**APPV-ID***” parameter to the registry root class:

HKEY_CLASSES_ROOT\InfoPath.Solution.4\shell\Open\command

“C:\ProgramData\Microsoft\AppV\Client\Integration\D24C3BDD-8FAD-44D3-998C-933F8F053682\Root\Office15\INFOPATH.EXE” /appvve:d24c3bdd-8fad-44d3-998c-933f8f053682_6b0281c5-bb0b-49fb-b52c-a6651e8ed2ed “%1”

1+
Continue reading...

GPUpdate on all Worker Machines

This Script will invoke an “GPupdate /force”  command on all CitrixWorker Machines.

0
Continue reading...